You have bookmarked items
Jump To:
Viewing Topic "Issue with Import Function"

5 Item(s)     Sort:  Newest Oldest

per page
 
  Post
Posted By: brave_heart
Total Posts: 47
Joined Date: Feb 7, 2019

I'm trying to update a bunch of business listings using the 'Import + Update' Function in the admin panel.

I want to update the 'business_hours' field. The import runs without errors and confirms the update.

Result:

While I can see the field being populated in the business_hours field in the ecp_jbusinessdirectory_companies table it doesn't show up in the front-end.

When I edit the business profile in the admin panel, I can see the business hours correctly populated. After just saving and closing the profile, the front-end template suddenly shows the business hours correctly.

Any idea what's missing?

Posted : Dec 2, 2019
Posted By: Robert Bal
Total Posts: 54
Joined Date: Jul 31, 2018

Hi brave_heart,

I noticed double comma if company is closed a certain day, not sure if can trigger issue? 

Unable to trace if breaks are stored.

/Robert

 

 

 

Posted : Dec 5, 2019
Posted By: brave_heart
Total Posts: 47
Joined Date: Feb 7, 2019

Hi Robert,

I think the issue is stemming from two tables that are involved. Wasn't yet able to reverse engineer it to fully understand....

- ecp_jbusinessdirectory_companies  field 'business_hours'

and

- ecp_jbusinessdirectory_company_provider_hours

Latter one stores a record for each weekday, start and end hour.

My guess is there is an issue that - when you do an upload - business_hours gets populated but not resolved into individual rows? But then, when you open it in the admin panel and save it, they get populated and the hours show up.

I might be off on this and need to test this more. Also a question: Does business_hours (which we touched directly in the DB) have to be EMPTY before you do an upload via the interface?

 

I hope George can shed some light on how to make it work.

 

 

 

Posted : Dec 5, 2019
Posted By: George Bara
Total Posts: 1497
Joined Date: Jun 17, 2013

Hi,

 

The business listing opening hours mechanism has changed and most probably the import mechanism has not been updated.
We will check this and release a fix for it 5.3.0 version that will be out in 1-2 weeks.

Posted : Dec 9, 2019
Posted By: brave_heart
Total Posts: 47
Joined Date: Feb 7, 2019

Thanks for the info George.

Looking forward to the new version.

Posted : Dec 11, 2019

5 Item(s)     Sort:  Newest Oldest

per page
 

Viewing Topic "Issue with Import Function"


      You have bookmarked items
Jump To:

Who is online

 
Users browsing this topic 1 logged customers:: 0 and guest 1 (based on users active over the past 5 minutes)