J-BusinessDirectory - Content Plugin Error Create record not permitted & other issues

Support Forum

You have 0 bookmarked items
 

 

3 Item(s)

Show per page

I bought and installed J-BusinessDirectory Content Plugin but I can’t use it or see how it works. Requesting refund - this will not work for us.

I followed the provided install instructions, published the plugin, and set the article category.

As admin, I have no button to create new articles under the listings admin area - but I noticed I can use standard Joomla articles and attach business listing ID (client will need me to find IDs ?! and new 'BUSINESS' tab is added to all joomla items - which looks like an other issue!).

As a customer I get the following error when clicking Add New Article and I verified the business selected should be allowed to add this: “Error Create record not permitted”.
[SOLVED with setting permissions] as admin, I then went to Joomla Articles >> Options >> Permissions (/administrator/index.php?option=com_config&view=component&component=com_content) and changed group 'Registered' permissions for 'Create' and 'Edit Own' to be 'Allowed' and saved - and now I can see that customers can now add and edit the article content .... but I see now we have other issues with this ...

Other issues:

  1. Customers can not save an article - Clicking Save / Versions / Cancel buttons goes to unknown page (/component/content?a_id=0&Itemid=465) and no new article is created nor is edited article saved ... it is locked ?!

  2. Customers can not add content - Content tab editior is not working, can not click in the field.
    [SOLVED with adding JCE profile for registered users]

  3. Customers can not add images - Images and Links tab does is not working - clicking select opens new page to attach existing images, but no ability to upload new image.
    [SOLVED with adding file system path 'images/customer/$id' and setting Folder Tree to 'No' in JCE profile for registered users]
www.ourfingertips.com - websites developed and managed @ ourfingertips Let us help you make the most of the technology at our fingertips
2 replies

Hi,

 

There seems to be some permission issues and URL issues on your website.
The articles are being added using the default Joomla edit article function. If this is not working then you have a Joomla issue or an editor issue.

Almost working...

When a customer uses 'Manage Artlcles' and uses 'Add new article' button to create an article it does not populate the Business ID as would be expected ... and then we only have a 'Save' button which saves and closes ... we need this to save and not close (Joomla issue? why not have both buttons as before?) ... so customers can keep workiing on thier unpublished articles. As it is now as soon as a cusomer clicks save they need to wait for an admin to manually publish their article so they can see it listed and could then edit it some more.

P.S. - can you please also extend how long we can stay logged into https://www.cmsjunkie.com/ - why kick us out at all? At least give us a few hours.

www.ourfingertips.com - websites developed and managed @ ourfingertips Let us help you make the most of the technology at our fingertips